Welcome, Guest. Please Login or Register
Dynon Avionics, Inc.
 
Welcome to the Dynon Avionics forum!
  HomeHelpSearchLoginRegister  
 
 
Page Index Toggle Pages: 1
Send Topic Print
D100 to Garmin xl300 (Read 3340 times)
Feb 17th, 2008 at 7:03pm

dgrwalker   Offline
New Member


Posts: 2
*
 
I am trying to make my D100 get GPS data from my Garmin 300 xl.   Here is what I have done.  I have hooked up Dynon pin 22
to pin 19 on the Garmin.  I have programed the D100 and I get the purple anouncement on the HSI that says, "waiting for GPS data".  I have Turned on Garmin I/0 port 2 plotter and set to 9600 baud.  Nothing is happening.  What else needs to be done?  Where did I go wrong? 
Don
 
IP Logged
 
Reply #1 - Feb 18th, 2008 at 12:36pm

Dynon Support   Offline
Forum Administrator
Dynon Employee
Dynon Technical Support

Posts: 13226
*****
 
I assume it is saying "waiting for GPS fix."

Usually this means we are getting data from your GPS, but it doesn't have satellite lock yet. Can you verify the message and verify that the GPS has lock?
 

Please do not use Private Messaging on forum to contact. For private support:
Email: support at dynonavionics dot com
Phone: 425-402-0433 (7am-5pm Pacific weekdays)
IP Logged
 
Reply #2 - Feb 18th, 2008 at 3:54pm

dgrwalker   Offline
New Member


Posts: 2
*
 
I assume I have a sat lock as I have a nice moving map that works on the 300 XL.  The message "waiting for GPS data"  sounds to me like it is not getting the data from the 300 xl.

Don
Heading out to work on RV-8
 
IP Logged
 
Reply #3 - Feb 19th, 2008 at 9:14am

Dynon Support   Offline
Forum Administrator
Dynon Employee
Dynon Technical Support

Posts: 13226
*****
 
Check that...

...pin 19 is the serial (rs232) output/transmit on that GPS
...the Garmin and the D100 share the same ground
...the Garmin is set to output NMEA data
...the 300xl has a satellite lock
 

Please do not use Private Messaging on forum to contact. For private support:
Email: support at dynonavionics dot com
Phone: 425-402-0433 (7am-5pm Pacific weekdays)
IP Logged
 
Reply #4 - Feb 21st, 2008 at 9:40pm

Ghostriver   Offline
Frequent Poster
Alberta

Gender: male
Posts: 22
**
 
Garmin 300XL, EFIS-D10A, HS34

Here is how I connected and set up My EFIS D-10A/EMS D10/HS34/MD41. Wiring from the GNC 300XL was done using the downloaded GNC 300 Installation Manual from the Garmin site.
The HS34 was connected as per the EFIS D-10A App 6-15. The GNC 300XL and MD41 kept giving a “Message “ alert “No Altitude Input”. I remembered that on the forum someone had a harness made up with pin 17  J101 on the 300XL marked “Dynon”.  (This is the RS232 in from the “Icarus 3000 or Shadin”, which gives altitude.) I connected Pin 13 EFIS (Serial Encoder TX) and 21 (EFIS Encoder GND) to Pin 17 (and gnd) on the 300XL and that now gave the 300XL the Altitude input it wanted. I used Format 4 on the EFIS altenc menu. On the 300XL setup I set I/O 1   IN set to Icarus-alt and OUT set to “Aviation”. ARINC 429 IN set to OFF and OUT set to COLLINS PL2.  The EFIS was INPUT 1: GAMA GPS, INPUT 2:NONE Speed LOW.
Everything works fine.
 
IP Logged
 
Reply #5 - Feb 25th, 2008 at 7:20pm

Ghostriver   Offline
Frequent Poster
Alberta

Gender: male
Posts: 22
**
 
With reference to my previous reply, I contacted Dynon and they confirmed that the "Course Select" on the 300XL is Label 100 and should work. I went to my aircraft and conected Pin 12 & 24 on the HS34 to pin 32 & 33 on the 300XL so that they are now both connected with Arinc 429 Input and Output (Ref; Previous reply) plus the EFIS alt encoder serial out to the 300XL serial in (as in my previous reply). I now have full functionality between the EFIS D10A/EMS D-10/HS34 and MD41 except the NAV/GPS switch on the MD41 does not function as this function is done on the HS34. I can now select the HSI course on the HS34 using the Course Select knob when I have selected "HOLD" on the HS34 without a message light.
The 300XL setup (or Test) page for Arinc Input 429 set to "Selected Course" and the EFIS D-10A Output is "ON" with speed "LOW".
Hope this helps anyone with the 300XL.

Cheers Bob
 
IP Logged
 
Reply #6 - May 31st, 2008 at 6:34pm

Ghostriver   Offline
Frequent Poster
Alberta

Gender: male
Posts: 22
**
 
A clarification to the above   "I can now select the HSI course on the HS34 using the Course Select knob when I have selected "HOLD" on the HS34 without a message light." This should read --when I have selected "HOLD" on the MD-41. The message light refers to the message "No Course Input"
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print