Welcome, Guest. Please Login or Register
Dynon Avionics, Inc.
 
Welcome to the Dynon Avionics forum!
  HomeHelpSearchLoginRegister  
 
 
Page Index Toggle Pages: 1
Send Topic Print
Should we update software? (Read 2026 times)
Jun 28th, 2014 at 6:57am

JimmyG   Offline
New Member
I love flying!

Posts: 1
*
 
We have recently bought a D1 and find that sometimes after turning and returning to level flight the the horizon bar does not match the real horizon. We are on Version 1.0.0574. We are aware of the downloadable Version 1.0.1296 and wondering whether to instal it. However, a friend who contacted a UK retailer was told, "that he had just been phoned by Dynon and asked not to sell any more at present until a GPS problem had been fixed. He said the older ones were not affected, but he had already started to wonder after 2 new ones had very recently been returned to him as " GPS not working" whereas no problems ever prior to that." He was trying to buy one.

Are we best advised to upgrade the software, do nothing yet or return the unit under warranty?  If we upgrade are we exposed to the GPS not working problem?
 
IP Logged
 
Reply #1 - Jun 30th, 2014 at 11:09am

Dynon Avionics   Offline
Dynon Official
Dynon Technical Support

Posts: 13203
*****
 
The GPS issue affected the external GPS connection only. So if you have a GPS lock with either the internal or external puck already, that doesn't affect you. But to make a long story short: yes, you should update your software. You'll see in the revision log that there was actually a change that could improve your performance since the version you already have installed. If that doesn't fix it, get in touch with our support staff, as that implies a sensor problem that we should have a look at.
 

Please do not use Private Messaging on form to contact. For private support:
Email: support at dynonavionics dot com
Phone: 425-402-0433 (7am-5pm Pacific weekdays)
IP Logged
 
Reply #2 - Jul 21st, 2014 at 5:11am

pilotinpa   Offline
New Member
I love flying!

Posts: 1
*
 
Dynon Avionics wrote on Jun 30th, 2014 at 11:09am:
The GPS issue affected the external GPS connection only. So if you have a GPS lock with either the internal or external puck already, that doesn't affect you. But to make a long story short: yes, you should update your software. You'll see in the revision log that there was actually a change that could improve your performance since the version you already have installed. If that doesn't fix it, get in touch with our support staff, as that implies a sensor problem that we should have a look at.


Just to clarify, I also am on 1.0.0574, and would like to update my software. It appears that the latest, and only version available is 1.0.1296. However, in the revision log it says:

"This bug was only present in D1 software version 1.0.1263 and should only be loaded by customers that had previously loaded 1.0.1263 to fix the external GPS reciever issue that version fixed."

Since I did not previously load 1.0.1263, is this the version I should use to upgrade my D1, or do I need to somehow get 1.0.0629? From reading other posts, it seems that those with Mooney's can experience the vibration-induces roll bias, and I fly a Mooney M20C. I do not presently use an external GPS connection, but might in the future.
 
IP Logged
 
Reply #3 - Jul 21st, 2014 at 6:57pm

Dynon Avionics   Offline
Dynon Official
Dynon Technical Support

Posts: 13203
*****
 
You can go right to the latest version that's on the site (and it will have the performance improvement that helps with vibration in some aircraft, which wasn't in 0574)
 

Please do not use Private Messaging on form to contact. For private support:
Email: support at dynonavionics dot com
Phone: 425-402-0433 (7am-5pm Pacific weekdays)
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print