Welcome, Guest. Please Login or Register
Dynon Avionics, Inc.
 
Welcome to the Dynon Avionics forum!
  HomeHelpSearchLoginRegister  
 
 
Page Index Toggle Pages: 1
Send Topic Print
Dl00 and EMS120 communication problems (Read 1256 times)
Jun 4th, 2016 at 1:21pm

n693w   Offline
New Member


Posts: 3
*
 
I've had a D100 and EMS120 installed in my aircraft since 2008.  The EMS is mounted on the right side of my panel and the D100 on the left.  I have the right half of the D100 set as EMS display and the EFIS on the left.

In the last week or so intermittently the EMS display disappears  and may come back in 2 minutes or 10 minutes. 

The EMS120 on the right sided of the instrument panel works normally.

I've checked all wiring and found no problems.

Any suggestions?

Ron B


 
IP Logged
 
Reply #1 - Jun 6th, 2016 at 10:10am

Dynon Support   Offline
Forum Administrator
Dynon Employee
Dynon Technical Support

Posts: 13226
*****
 
If you are intermittently losing display of engine information on your EFIS-D100, but see no disruption on the EMS-D120's display, then the problem could be in the data communication between the EFIS and EMS units.

Your focus should be on the DSAB wires connecting the two units -- blue and green wires.  If you have checked the wires and connections and found no intermittent connection issues, then there may be a problem in either the EFIS or EMS unit.

Recommend you contact our Technical Support staff directly for steps to troubleshoot further, or possibly to arrange for warranty repair.  Reach them either via E-mail at Support@DynonAvionics.com or by phone at 425-402-0433 Option 1.
 

Please do not use Private Messaging on forum to contact. For private support:
Email: support at dynonavionics dot com
Phone: 425-402-0433 (7am-5pm Pacific weekdays)
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print