Welcome, Guest. Please Login or Register
Dynon Avionics, Inc.
 
Welcome to the Dynon Avionics forum!


  HomeHelpSearchLoginRegister  
 
 
Page Index Toggle Pages: 1
Send Topic Print
Noise coupling from display PWM (Read 208 times)
Feb 3rd, 2018 at 5:35pm

Hiroo   Offline
Frequent Poster
I love flying!

Posts: 19
**
 
I am getting to the point I am firing up the HDX alongside the audio and RF systems on my panel.  It is mostly working but I am getting the dreaded audio coupling from the display PWM.  I know it is the display backlight because the intensity of the hum comes and goes with the display backlight.  For example, during the boot cycle, the hum starts full volume, then fade and comes back as the HDX logo brightens, goes away on black screen, then once the system diagnostic screen comes on, it is steady.  I can influence the intensity by adjusting the brightness, too.  The hum is about 120Hz (about double the common 60Hz hum).
Thinking I have an inadequate grounding, I tried jumping the HDX case to radio frame GND.  That did not materially change the intensity or the quality of the hum.
Any suggestion on where I should look next?  When I turn the HDX off, the hum goes away completely.

Hiroo
 
IP Logged
 
Reply #1 - Feb 5th, 2018 at 7:08am

RayInGA   Offline
Senior Member
I love aviation!
Richmond Hill, GA

Gender: male
Posts: 423
****
 
This is almost always a grounding issue. Also check that your shielded wires are grounded on only one end and, ideally, at the source of potential noise.
« Last Edit: Feb 5th, 2018 at 7:08am by RayInGA »  

Ray Eaker
RV-7A flying since 27 Jan 2017
Dual Skyview 1000T with all available Dynon VFR goodies
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print